Go Back   The Older Gamers Forums > TOG Public Forums > RPG, Simulation, Strategy and Others > Minecraft (Public)

Minecraft (Public) Build it and they will come

Reply
 
LinkBack Thread Tools
Old 5th January 2011, 10:17 AM   #11 (permalink)
Ace - Post: 8367 TOG Silver Level Supporter
 DaedalusAlpha's Avatar

Default

After two very unfortunate lag related deaths where I lost everything I owned of value I decided to see if the creative server is as laggy, and thus this being the betas fault.

The creative server, while more laggy in beta than in alpha, is still a lot less laggy than the SMP server. This is wierd. The only thing different between them should be the enemies in regard to processing power/bandwidth. So why is it so much more laggy? (well it also has more users, but the lag doesn't change at all in regard to that)

It's really really hard for me to play on it right now because the enemies don't appear where they are supposed to be which means:
1) I get attacked before I actually see the enemy
2) I can't fight back because I essentially only hit air (the mob has already moved to some other location but this isn't updated in my client)

I also got dropped into lava while mining obsidian. In normal cases if one has flowing water on top, it will flow into the hole and create obsidian below the block you just mined before it's destroyed by the lava underneath. Now thanks to lag I instead got washed into the hole before obsidian was created, and then burned to death before I even realized I was in lava. Yey.

Other interesting artefacts:
* From time to time the game sort of stutters for a few seconds even though the computer doesn't do anything extra, during this time the server-client sync is usually better than normal.
* When I go close to trees that has just grown I often get stuck on invisible leaves that obviously are there in the server but not in the client. This results in you being able to move quite some distance and then get rubberbanded back to the tree where you got stuck a couple of seconds later.
* My brother sometimes get it like he can't move for a couple of seconds and then he skips forward a long distance. This has at least once resulted in him walking over a cliff and falling to his death.
__________________
EVE Online characters:
Daedalus II
ex-CEO TOGOA, Daedalus III slave of Daedalus II
GW2 characters:
Little Molok Asura Engineer


"Each day I don't get an attempt on my life by a robot from the future I see as a personal failure"

Last edited by DaedalusAlpha; 5th January 2011 at 10:35 AM.
DaedalusAlpha is offline   Reply With Quote

Old 5th January 2011, 03:46 PM   #12 (permalink)
Dangerous - Post: 581

Amused
Default

I don't tend to get much lag unless I go near areas that are darker and where mobs actually are or where they may spawn. It is usually decent apart from that.

I suspect it is the game mob calculations or data transfer to the client that is messing it up. I, of course, have no actual real basis for these suspicions other than the locations I am when I get any serious lag.
C.
__________________
Currently playing: Archeage, Landmark (sometimes - waiting on more)
Currently retired from playing: EQ2, Vanguard Saga of Heroes, Fallen Earth, WoW, Mortal Online, Perpetuum, Rift, SWTOR, EVE (again), Minecraft
Cheith is offline   Reply With Quote
Old 5th January 2011, 07:41 PM   #13 (permalink)
Ace - Post: 8367 TOG Silver Level Supporter
 DaedalusAlpha's Avatar

Default

Wouldn't be totally surprising if that was the reason as I have a mob spawner right underneath my base.
__________________
EVE Online characters:
Daedalus II
ex-CEO TOGOA, Daedalus III slave of Daedalus II
GW2 characters:
Little Molok Asura Engineer


"Each day I don't get an attempt on my life by a robot from the future I see as a personal failure"
DaedalusAlpha is offline   Reply With Quote
Old 5th January 2011, 08:28 PM   #14 (permalink)
Deadly - Post: 2181
 blacksok's Avatar

Dead
Default

Its getting almost unplayable for me

On the other hand, i got some great footage of me teabagging a spider client side when there was no sync to the server
__________________
blacksok is online now   Reply With Quote
Old 5th January 2011, 10:07 PM   #15 (permalink)
Ace - Post: 8367 TOG Silver Level Supporter
 DaedalusAlpha's Avatar

Default

How far from the server do you live? what time do you play? maybe we can find similarities between us?
__________________
EVE Online characters:
Daedalus II
ex-CEO TOGOA, Daedalus III slave of Daedalus II
GW2 characters:
Little Molok Asura Engineer


"Each day I don't get an attempt on my life by a robot from the future I see as a personal failure"
DaedalusAlpha is offline   Reply With Quote
Old 5th January 2011, 10:53 PM   #16 (permalink)
Team Fortress 2
Deadly - Post: 1389

Default

btw, the creative and survival servers are two different java threads on the same machine. so its unlikely that a hosting problem is causing your lag (networking, hosting resources etc).
perhaps client side resources, or latency, or buggy minecraft I'm thinking.
Or the creative server lag is not noticeable.
exekewtable is offline   Reply With Quote
Old 6th January 2011, 08:01 AM   #17 (permalink)
Ace - Post: 8367 TOG Silver Level Supporter
 DaedalusAlpha's Avatar

Default

Today when I tried it was a lot less laggy for me, although others stated it was laggier than usual. There was also less people online than before so that might have an effect.
__________________
EVE Online characters:
Daedalus II
ex-CEO TOGOA, Daedalus III slave of Daedalus II
GW2 characters:
Little Molok Asura Engineer


"Each day I don't get an attempt on my life by a robot from the future I see as a personal failure"
DaedalusAlpha is offline   Reply With Quote
Old 6th January 2011, 09:01 AM   #18 (permalink)
Deadly - Post: 1663
 DangerMouse's Avatar

Amused
Default

Daedalus from your profile it says you are in Sweden, if that is still correct and the servers are in Australia, the ping time is going to over 200ms at the best of time - which is fine for the creative server but for the SMP server where you are attacking it is going to cause issues...

Also MC hasnt got the best network code has it?!

"Reminds me when I was a lad, playing on the 56k dial-up modem, playing CS 1.6 with a ping of over 350ms! Those were the days!!!!!..... grumble kids today grumble"
DangerMouse is offline   Reply With Quote
Old 6th January 2011, 09:05 AM   #19 (permalink)
Deadly - Post: 2181
 blacksok's Avatar

Dead
Default

I'm in sydney and find the lag issues really bad of an avo\evening, but i have the cant hit mobs without them hitting me thing all the time
__________________
blacksok is online now   Reply With Quote
Old 6th January 2011, 09:13 AM   #20 (permalink)
Deadly - Post: 1663
 DangerMouse's Avatar

Amused
Default

Blacksok which ISP are you with? What connection? If ADSL are you on a RIM?

Quote:
Originally Posted by blacksok View Post
lag issues really bad of an avo\evening
If you are on a RIM it would explain this - your RIM is being congested in the evenings... how do other on-line games play at that time?

Last edited by DangerMouse; 6th January 2011 at 09:37 AM.
DangerMouse is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT +11. The time now is 08:48 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0