Go Back   The Older Gamers Forums > TOG Public Forums > Shooter Games: The Range

Shooter Games: The Range Public discussion forum for all shooter games.

Reply
 
LinkBack Thread Tools
Old 19th November 2010, 10:08 PM   #1 (permalink)
Ned
Public Forum Coordinator
Guru - Post: 11366
 Ned's Avatar

Default Far Cry 2 and PunkBuster

For those that may not know, PunkBuster™ by Even Balance, Inc. is an Anti-Cheat software technology for online gaming.

PunkBuster is no longer contratced to support Far Cry 2. For ranked multiplayer Far Cry 2 gaming, PunkBuster is required to be enabled on both the server and client which can be a problem with new installs of the game because the PunkBuster client will now not update automatically and you can no longer manually get the required updates from the PB website. Also, after the 1.03 patch the game's remote admin functions broke so now PB is the only way to remotely administor a Far Cry 2 server. Server utilities exist but these do not function remotely.

I've made available for download a Far Cry 2 PunkBuster install.
Server version v1.734 | A1392 C2.159
Client version v2.159 | A1392

If you are having PunkBuster issues then try installing this pack (save your original pb folder first).


Instructions.
-make a copy of your original pb folder
-remove pb folder from game install
-add the downloaded pb folder to game install

\Far Cry 2\bin\pb



Download - LINK ~5MB -




I have a Far Cry 2 server currently running. All welcome. Capture the Diamond and Uprising gametypes are played on the server. More details on all of this soon.

IP 202.60.93.2
Ned is offline   Reply With Quote

Old 20th November 2010, 01:57 PM   #2 (permalink)
Retired Captain
Elite - Post: 3619
 Unknown's Avatar

Default

Quote:
Originally Posted by Ned View Post
I've made available for download a Far Cry 2 PunkBuster install.
Server version v1.734 | A1392 C2.159
Client version v2.159 | A1392
For my copy of FC2 (via Steam), I checked and it already had the most up-to-date client files in the "...\far cry 2\pb\bin\dll" directory, namely "wa001392.dll" and "wc002159.dll" - tried on Ned's server this afternoon and it didn't matter that my server DLL was one version behind, as long as the client files were right it all worked fine.
__________________
"I am a busy man and I can't be bothered to punch you at the moment. Here's my fist. Kindly run towards it as fast as you can."
- Blackadder: The Cavalier Years
Unknown is offline   Reply With Quote
Old 30th December 2010, 04:13 PM   #3 (permalink)
Retired Captain
Retired Captain
Elite - Post: 4575
 Genghoidal's Avatar

Fine
Default

Just had a run on your server.. all working good.. cya in there sometime
__________________
Genghoidal is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT +11. The time now is 01:56 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0